Mobile Banking on your telephone or tablet

Use the correct Android or iOS version

Devices supported by the app

Why you need the latest version of iOS or Android

Obsolete versions of iOS or Android use outdated security measures, meaning that new Mobile Banking features will not work, as they use the latest Android and iOS functionality. Unfortunately, our app will therefore not run on obsolete versions, even if your device is still in excellent working order.

 

When the app no longer works

Check your version of iOS or Android and try to upgrade to a later version. Read on to find out how to do this. If you can do it, you will be able to continue using the app.

Internet Banking is available

If your device is too old to run the app, you can do your banking using Internet Banking. Simply log in from any of our webpages, including on your tablet or mobile phone. Scroll all the way up and click the yellow log-in button in the top right-hand corner.

How to update iOS or Android

iPhone or iPad (iOS)

  • Go to ‘Settings’ on your iPhone or iPad.
  • Tap ‘General’.
  • Tap ‘Software Update’. Here you can see which iOS version your device is running. If an update is available, you will find it here. 
  • Tap ‘Install Now’ to install the update and follow the instructions.

Mobile phones or tablets using Android

  • Go to ‘Settings’ on your mobile phone or tablet.
  • Tap ‘About phone/tablet’, followed by ‘Device info’.
  • Tap ‘System’, followed by ‘System updates’. Here you can see which version of Android your device is running. If an update is available, you will find it here. 
  • Tap ‘Install’ to install the update and follow the instructions.